PDA

Visualizza la versione completa : Boot Manager MBR compromesso, non riesco a reinstallare LiLo o Grub


trillullero
10-03-2006, 23:44
Ho ripristina l'immagine di una partizione (hda6) con partimage ed il bootloader (lilo) installato sull'MBR non funziona più.
Le mie partizioni sono le seguenti
hda1 windows nascosta
hda2 windows
hda5 swap
hda6 gentoo
hda7 dati
hda8 mepis

Per ripristinare lilo eseguo il boot da knoppix 3.9 e poi il chroot
mount /mnt/hda6
mount -t proc none /dev/hda6/proc
chroot /mnt/hda6

il file di configurazione di lilo è ok e quindi lancio
lilo

ed ottengo

Fatal: open: /dev/hda: permission denied

Ho provato quindi a fare il chroot in hda8 ed installare grub sull'MBR ma anche in questo caso ottenfo errori:

grub-install /dev/hda

entry not specified
/sbin/grub-install: line 433: /dev/null: permission denied (ripetuto diverse volte)
The file /boot/grub/stage1 not read correctly

Morale, non riesco più ad installare un boot manager sull'MBR.
Qual'è la causa e come posso risolvere?

francofait
11-03-2006, 00:27
Originariamente inviato da trillullero
Ho ripristina l'immagine di una partizione (hda6) con partimage ed il bootloader (lilo) installato sull'MBR non funziona più.
Le mie partizioni sono le seguenti
hda1 windows nascosta
hda2 windows
hda5 swap
hda6 gentoo
hda7 dati
hda8 mepis

Per ripristinare lilo eseguo il boot da knoppix 3.9 e poi il chroot
mount /mnt/hda6
mount -t proc none /dev/hda6/proc
chroot /mnt/hda6

il file di configurazione di lilo è ok e quindi lancio
lilo

ed ottengo

Fatal: open: /dev/hda: permission denied

Ho provato quindi a fare il chroot in hda8 ed installare grub sull'MBR ma anche in questo caso ottenfo errori:

grub-install /dev/hda

entry not specified
/sbin/grub-install: line 433: /dev/null: permission denied (ripetuto diverse volte)
The file /boot/grub/stage1 not read correctly

Morale, non riesco più ad installare un boot manager sull'MBR.
Qual'è la causa e come posso risolvere?

Vedo che hai SimplyMepis installata
Rilancia il suo cdrom in live mode ed utilizza le sue funzioni di ripristino grub dove lo vuoi , da mepis oscenter

trillullero
11-03-2006, 00:46
Grande Franco!!! Mepis è partita! Era la cosa più banale da fare e nn ci ho pensato. Però mi restano i dubbi...perchè la mia procedura non ha funzionato? L'ho fatta molte altre volte senza problemi.
Ha a che fare con il canale sata?

Prima di installare grub ho ripetuto la procedura di prima MA montando manualmente la partizione di gentoo:
mount -t reiserfs /dev/hda6 /mnt/hda6
mount -t proc none /mnt/hda6/proc

lilo

ed ho ottenuto il seguente errore (diverso da prima)
---------

Warning: '/proc/partitions' does not match '/dev' directory structure.
Name change: '/dev/cloop0' -> '/tmp/dev.0'
Warning: '/dev' directory structure is incomplete; device (240, 0) is missing.
Warning: '/dev' directory structure is incomplete; device (180, 0) is missing.
Warning: '/dev' directory structure is incomplete; device (180, 1) is missing.
Added gentoo
Device 0x0300: Inconsistent partition table, 2nd entry
CHS address in PT: 243:0:1 --> LBA (244944)
LBA address in PT: 3903795 --> CHS (3872:13:1)
Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified
If not sure, first try IGNORE-TABLE (-P ignore)
---------

Sarei proprio curioso di capire perchè lilo non si è installato.
Grazie 1000 bye ; )

Loading