PDA

Visualizza la versione completa : [Debian] Installare PYGKT


ombra
11-03-2006, 19:03
Ciao a tutti
Devo installare il pacchetto PYGTK per python, voglio installare "tutto a mano", perch ho avuto dei problemi con apt-get...
Stavo compilando ma mi da errore, non trova glib, cos' questo pacchetto?
Serve qanche qualche altro pacchetto per installare le pygtk ??

Grazie mille :ciauz:

sacarde
11-03-2006, 19:40
http://www.badpenguin.org/press/infomedia/compilare.html

U-bahn
11-03-2006, 19:51
Originariamente inviato da ombra
Ciao a tutti
Devo installare il pacchetto PYGTK per python, voglio installare "tutto a mano", perch ho avuto dei problemi con apt-get...
Stavo compilando ma mi da errore, non trova glib, cos' questo pacchetto?
Serve qanche qualche altro pacchetto per installare le pygtk ??

Grazie mille :ciauz: gli servono le glib e python ( :madai!?: )
in pi, se vuoi: libglade, gtk+-2.*.*, pycairo e sicuramente qualcos'altro che non ricordo

in ogni caso dovrebbe essere scritto nel readme

ombra
11-03-2006, 23:02
si mi servono i pacchetti per installare le pygtk per utilizzare con python, qualcuno mi pu elencare i pacchetti da installare, non voglio utilizzare apt-get :fagiano:

GRAZIE :ciauz:

U-bahn
11-03-2006, 23:12
Originariamente inviato da ombra
qualcuno mi pu elencare i pacchetti da installare stai scherzando, vero ?!?

ombra
12-03-2006, 00:28
Originariamente inviato da U-bahn
stai scherzando, vero ?!?

no perch??
Installo glib e mi da errore su un altro, installo pkg-config e mi da errore in gtk, un casino, non c' una lista di tutti i file che bisogna instllare per utilizzare le gtk?


grazie :fagiano:

cacao74
12-03-2006, 00:40
Originariamente inviato da ombra
non c' una lista di tutti i file che bisogna instllare per utilizzare le gtk?

visto che non vuoi utilizzare apt|aptitude|dpkg|dselect|synaptic o altro, dovrai arrangiarti con i sorgenti. il che significa leggersi i vari READM, INSTALL, verificare di soddisfare i requisiti (leggasi dipendenze) per poter installare i vari pacchetti. Ovviamente questa operazione da applicare ricorsivamente per ogni pacchetto la cui installazione necessaria.

ciao

ombra
12-03-2006, 00:57
Originariamente inviato da cacao74
visto che non vuoi utilizzare apt|aptitude|dpkg|dselect|synaptic o altro, dovrai arrangiarti con i sorgenti. il che significa leggersi i vari READM, INSTALL, verificare di soddisfare i requisiti (leggasi dipendenze) per poter installare i vari pacchetti. Ovviamente questa operazione da applicare ricorsivamente per ogni pacchetto la cui installazione necessaria.

ciao


in poche parole me la sono cercata!!!!!!!!! :cry:

Cavolo volevo incominciare ad impararmi ad installare i pacchetti da shell, ma niente!!!! :messner:

spariggio82
12-03-2006, 01:49
Senti io ho installato gli stessi pacchetti e molti altri in questi giorni. Io ho dovuto fare un mix tra apt e source.

In particolare le pygtk le ho installate a mano ma non ho avuto grossi problemi di dipendenze (che ricordi).Mi pare che ho dovuto aggiornare le libgtk con apt e qualche altra cosa . . .

Spero di esserti stato utile (almeno un pochino)

ombra
12-03-2006, 02:04
ok vedo un p se risolvo!!!

grazie :ciauz:

Loading