PDA

Visualizza la versione completa : LiLo


FinalFantasy
13-03-2006, 20:29
Ciao a tutti...
Ho installato fc5, però ho ancora problemi con grub come ce li avevo con debian. In pratica, grub nel mio pc è verametne ostinato. Ho scaricato i file compiati su lilo e una piccola docs su come costruire il file lilo.conf.

Fatto cio, faccio /sbin/lilo e riavvio. Quando deve partire lilo, compare

L

e poi il successione 0A 0A 0A, così

L 0A 0A

fino a riempire tutto lo schermo. Ora non so cosa vuol dire, ma vorrei un po' capire come diavolo far partire questo dannato linux...

Io ho configurato lilo in questo modo



boot=/dev/hda
map=/boot/map
compact
prompt
timeout=30
other=/dev/hda1
label=windows
image=/boot/vmlinuz-2.6.15-1.1955_FC5
label=linux
root=/dev/hdc5


Inoltre la documentazione diceva di mettere
install=boot/boot.b
xo lo dimenticato
i file boot.b e map sono file che devo già avere o se li crea lui? nel bin che ho preso nn ci sono. La initrd come si imposta? non c'è la clausola per il default (visto che prende sempre la prima voce)?

Inoltre mi ha detto, al momento che ho fatto /sbin/lilo,
Warning: the boot record ecc ecc

diceva in poche parole che il settore di avvio e un'altra cosa si trovano in dischi differenti, ma non ho capito cosa voleva dire e poi mi ha mostrato
Added windows *
Added linux

please, help me

mykol
13-03-2006, 20:38
se ti può servire ecco il mio (in parte)...

Ma in FC5 non puoi scegliere LILO in fase di installazione ?

==================================

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/it-latin1.klt
menu-scheme=wb:bw:wb:bw
prompt
nowarn
timeout=100
message=/boot/message
image=/boot/vmlinuz
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="resume=/dev/hda5 splash=silent"
vga=788
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda1
initrd=/boot/initrd.img
append="splash=silent resume=/dev/hda5"
image=/dyne/linux
label="dyne:bolic"
root=/dev/ram0
initrd=/dyne/initrd.gz
append="resume=/dev/hda5"
vga=788
read-write

image=/boot/vmlinuz
label="alt_linux-nonfb"
root=/dev/hda1
initrd=/boot/initrd.img
append="resume=/dev/hda5"
read-only
image=/boot/vmlinuz-2.6.8.1-12mdk
label="alt_2.6.8.1-12"
root=/dev/hda1
initrd=/boot/initrd-2.6.8.1-12mdk.img
append="splash=silent resume=/dev/hda5"
vga=788
read-only
other=/dev/hda6
label="hda6"

FinalFantasy
13-03-2006, 21:36
Originariamente inviato da mykol
Ma in FC5 non puoi scegliere LILO in fase di installazione ?

no...permette solo di installare grub che, non so x quale motivo, non vuole funzionare...
Io mi sn preoccupato di quelle 0A 0A 0A che compaiono

FinalFantasy
13-03-2006, 22:26
uffa...nn so + ke fare...ho reinstallato lilo usando un po' quella configurazione, ma mi spunta questo

L 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A 0A

in continuazione...
ma ke vuol dire?

grub nn va, questo ha la fissazione dello zeroA (0A)
cioè...con il pc ke avevo prima funzionava meglio...

francofait
13-03-2006, 22:47
Originariamente inviato da FinalFantasy
Ciao a tutti...
Ho installato fc5, però ho ancora problemi con grub come ce li avevo con debian. In pratica, grub nel mio pc è verametne ostinato. Ho scaricato i file compiati su lilo e una piccola docs su come costruire il file lilo.conf.

Fatto cio, faccio /sbin/lilo e riavvio. Quando deve partire lilo, compare

L

e poi il successione 0A 0A 0A, così

L 0A 0A

fino a riempire tutto lo schermo. Ora non so cosa vuol dire, ma vorrei un po' capire come diavolo far partire questo dannato linux...

Io ho configurato lilo in questo modo



boot=/dev/hda
map=/boot/map
compact
prompt
timeout=30
other=/dev/hda1
label=windows
image=/boot/vmlinuz-2.6.15-1.1955_FC5
label=linux
root=/dev/hdc5


Inoltre la documentazione diceva di mettere
install=boot/boot.b
xo lo dimenticato
i file boot.b e map sono file che devo già avere o se li crea lui? nel bin che ho preso nn ci sono. La initrd come si imposta? non c'è la clausola per il default (visto che prende sempre la prima voce)?

Inoltre mi ha detto, al momento che ho fatto /sbin/lilo,
Warning: the boot record ecc ecc

diceva in poche parole che il settore di avvio e un'altra cosa si trovano in dischi differenti, ma non ho capito cosa voleva dire e poi mi ha mostrato
Added windows *
Added linux

please, help me

hai seminato per strada initrd=/boot/initrd.img-2.6.15-1955_fc5

Poco male se stanotte ripiove domattina trovi le sue piantine fiorite :D :D :D

FinalFantasy
13-03-2006, 22:51
ma il problema mio è che lilo nemmeno parte...mi mostra una sequenza di 0A che aumenta col passare del tempo e io nn ho la + pallida idea di perché faccia così

francofait
13-03-2006, 22:55
Originariamente inviato da FinalFantasy
ma il problema mio è che lilo nemmeno parte...mi mostra una sequenza di 0A che aumenta col passare del tempo e io nn ho la + pallida idea di perché faccia così

Lilo non ammette errori difatti, non è come grub che va a prendersi il menu.lst in /boot/grub ogni volta che avvii.
Si installa su mbr tutto intero. /etc/lilo.conf serve solo per
lanciare il comando lilo -v quando installi o aggiorni il bootloader.

FinalFantasy
13-03-2006, 23:02
Originariamente inviato da francofait
Lilo non ammette errori difatti, non è come grub che va a prendersi il menu.lst in /boot/grub ogni volta che avvii.
Si installa su mbr tutto intero. /etc/lilo.conf serve solo per
lanciare il comando lilo -v quando installi o aggiorni il bootloader. io ho eseguito solamente /sbin/lilo senza -v

è grave?

francofait
13-03-2006, 23:16
Originariamente inviato da FinalFantasy
io ho eseguito solamente /sbin/lilo senza -v

è grave?

-v sta x verifica , passandolo ti restituisce l'errore nello script e il comando non viene eseguito x cui si è buona norma usarlo

francofait
13-03-2006, 23:23
Piuttosto usando grub che errore ti dà.?
Fedora C4 ed anche C5 x ora di solito tendono ad installare lo script menu.lst e /etc/fstab con errori nella definizione della root. e della swap
ed è sufficente correggerli x rimediare l'avvio corretto del SO

Loading