PDA

Visualizza la versione completa : [Debian] Errore aggiornamento gtk


Kamui
13-03-2006, 22:51
Ciao,
tentando di aggiornare gxine ha chiesto di aggiornare le gtk, dalla versione 2.6.x installata alla 2.8.x
Sono sorti dei problemi e ora ho qualche casino con alcune applicazioni, quindi vorrei aggiornare le gtk. Ma quando ci provo:


root(/home/sly) #apt-get install libgtk2.0-0
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
libgtk2.0-0 gi alla versione pi recente.
consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libgtk2.0-0: Dipende: libgtk2.0-common (>= 2.8.13-1) ma non sta per essere installato
Dipende: libgtk2.0-bin (>= 2.8.13-1) ma 2.6.4-3 sta per essere installato
libgtk2.0-dev: Dipende: libxcursor-dev ma non sta per essere installato
libpango1.0-0: Dipende: libpango1.0-common (>= 1.10.4-1) ma non sta per essere installato
librsvg2-common: Dipende: libgtk2.0-common (>= 2.4.1-3) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).


root(/home/sly) #apt-get install libgtk2.0-common
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libgtk2.0-0: Dipende: libgtk2.0-bin (>= 2.8.13-1) ma 2.6.4-3 sta per essere installato
libgtk2.0-dev: Dipende: libxcursor-dev ma non sta per essere installato
libpango1.0-0: Dipende: libpango1.0-common (>= 1.10.4-1) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).


root(/home/sly) #apt-get install libgtk2.0-bin
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libgtk2.0-0: Dipende: libgtk2.0-common (>= 2.8.13-1) ma non sta per essere installato
libgtk2.0-dev: Dipende: libxcursor-dev ma non sta per essere installato
libpango1.0-0: Dipende: libpango1.0-common (>= 1.10.4-1) ma non sta per essere installato
librsvg2-common: Dipende: libgtk2.0-common (>= 2.4.1-3) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).

#apt-get -f install
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Preconfigurazione dei pacchetti in corso
(Lettura del database ... 124856 file e directory attualmente installati.)
Rimuovo gxine ...
dpkg: errore processando gxine (--remove):
impossibile rimuovere `/usr/lib/mime/packages/gxine': Permission denied
Sono occorsi degli errori processando:
gxine
E: Sub-process /usr/bin/dpkg returned an error code (1)


C' qualche problema in questi giorni? O sono io che devo aggiornare qualcosa che non afferro? O mi conviene fare il dist-upgrade completo? :stordita:

Grazie :ciauz:

andy caps
14-03-2006, 19:49
dipende anche da cosa hai nel sources.list

se hai la stable ed hai messo la unstable puo' dare questi errori se non aggiorni il sistema

Kamui
15-03-2006, 18:01
Ho la unstable ma da un po' di mesi la aggiorno a membro di canide, nel senso che aggiorno solo i programmi di cui mi interessa avere l'ultima versione senza fare dist-upgrade; l'ultimo dist-upgrade l'ho dato quasi un anno fa...

andy caps
15-03-2006, 19:59
se non aggiorni un po' difficile gestire le dipendenze e anche l'agiornamento da sarge a sid gia problematico attualmente

Kamui
15-03-2006, 20:30
E com' la sid in questi tempi?

andy caps
15-03-2006, 20:37
perfetta

kde3.5.1 xorg 6.9
gira meglio di sarge secondo me

l'aggiornamento era un po traumatico fino a giorni fa
udev aveva problemi con i kernel inferiori al 2.6.12 e con hotplug e spesso era un po' un cane che si morde la coda
adesso non so

installata dalla base con il sources della sid non da il minimo problema

Kamui
21-03-2006, 11:41
Anche il dist-upgrade mi d problemi :(



Mi preparo a sostituire libc6 2.3.5-6 (con .../libc6_2.3.6-3_i386.deb) ...
Spacchetto il rimpiazzo di libc6 ...
dpkg: errore processando /var/cache/apt/archives/libc6_2.3.6-3_i386.deb (--unpack):
impossibile creare `./lib/ld-2.3.6.so': Permission denied
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Sono occorsi degli errori processando:
/var/cache/apt/archives/libc6_2.3.6-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

#ls -l / |grep lib && ls -l /lib/ld-*
drwxr-xr-x 12 root root 4264 2006-02-01 09:47 lib
-rwxr-xr-x 1 root root 90028 2005-08-29 19:45 /lib/ld-2.3.5.so



che razzo ?! :confused: :incupito:
Problemi al filesystem? In /lib non posso scrivere neanche da root... solo in /lib per...

andy caps
21-03-2006, 14:46
difficile da dire :confused:

hai provato ???

dpkg -i --force-all /var/cache/apt/archives/libc6_2.3.6-3_i386.deb

Kamui
21-03-2006, 16:41
Probabilmente mi si era corrotto il filesystem, non la prima volta che reiserfs mi fa questi scherzetti...
ho creato una nuova partizione di root e ci ho copiato il contenuto della vecchia, ora ho fatto il dist-upgrade.
Ci sono per dei problemi :dh:

Innanzitutto non posso pi usare alsa da utente normale, cercando di usare alsamixer infatti ottengo snd_ctl_open failed for default: permission denied nonostante /dev/audio*, /dev/dsp/*, /dev/snd/*, /dev/sequencer* e /dev/midi* abbiano gruppo audio e il mio utente appartenga al gruppo audio.

Inoltre i terminali virtuali non funzionano, mrxvt mi stalla e gli altri (xterm, aterm, rxvt, Terminal...) si suicidano all'istante.

Anche altri programmi, ad esempio rox e gxine, si suicidano...

E la gestione dei font sembra essere cambiata, ora dal centro di controllo di xfce non riesco a cambiare i font di tutte le applicationi GTK2; per alcune posso usare gtk-theme-switch2 mentre ad esempio Firefox ha dei font minuscoli che non riesco a cambiare.

http://img456.imageshack.us/img456/9031/schermata0sc.jpg

Aiut! :( :oVVoVe:

Kamui
21-03-2006, 18:08
Il problema di Firefox sembra essere che se in xorg.conf imposto una risoluzione pi alta di 1024x768, poi anche usando questa mi tiene i font pi piccoli... :dott:

Per tutto il resto, da root funziona *tutto*... alsa, pseudo-terminali e rox e gxine...
Ma che cacchio di permessi devo impostare?? :nonlodire
/dev/pty* hanno rw per tutti, per alsa ho gi scritto nell'altro post e per rox e gxine non saprei dove andare a cercare.

Loading