PDA

Visualizza la versione completa : [gentoo] xorg e driver nvidia


osvi
18-03-2006, 16:01
ho dato emerge nvidia-glx (e relativo kernel nvidia), solo che startx esce con un bruttissimo (EE) NVIDIA: failed to load the nvidia module

come mai? e' installato eppure :oVVoVe:

andy caps
18-03-2006, 16:30
modprobe nvidia che dice ??

hai fatto correttamente il link linux in /usr/src ??

osvi
18-03-2006, 20:04
ares fra # modprobe nvidia
FATAL: Module nvidia not found.
ares fra # lsmod |grep nv
nvidiafb 52892 0
cfbcopyarea 3968 1 nvidiafb
cfbimgblt 3072 1 nvidiafb
cfbfillrect 4096 1 nvidiafb
nvidia_agp 8092 1
agpgart 36296 1 nvidia_agp
ares fra #


s, il link presente :(

andy caps
18-03-2006, 20:45
dai un uname -r
devi fare il link in usr/src al kernel in uso

se il driver non c' lo hai installato su un altro kernel :bh:

osvi
18-03-2006, 21:59
ma ho un solo kernel :oVVoVe:


ares src # ls -lsa
total 38916
1 drwxr-xr-x 3 root root 6 Mar 18 21:57 .
1 drwxr-xr-x 16 root root 18 Mar 18 21:56 ..
0 -rw-r--r-- 1 root root 0 Feb 14 01:03 .keep
0 lrwxrwxrwx 1 root root 14 Mar 17 18:47 linux -> linux-2.6.15.6
2 drwxrwxrwx 19 root root 33 Mar 18 15:19 linux-2.6.15.6
38912 -rw-r--r-- 1 root root 39845515 Mar 17 18:45 linux-2.6.15.6.tar.bz2
ares src # uname -r
2.6.15.6

andy caps
18-03-2006, 22:07
allora prova reinstallari
emerge nvidia-kernel nvidia-glx opengl-update :bh:

controlla che lo dia installato

osvi
19-03-2006, 01:18
reinstallati, niente -.-
provo l'installer .run di invidia.. da errore di compilazione

guardo nel file log e dice che ci stanno altri moduli nvidia fb caricati.. rmmod e modprobe nvidia ha funzionato alla grande :D

solo non capisco.. il file config del kernel che avevo su debian, e non dovevo scaricare niente.. mah.. vabb.. mi sto consolando con XGL, , ... .......... :sbav: :sbav: :sbav: :sbav: :sbav:

PinguinoGoloso
19-03-2006, 01:55
E' il modulo rivafb che probabilmente gli d fastidio. Toglilo con rmmod, dai un depmod -ae e riprova a riemergere il driver.

Loading