PDA

Visualizza la versione completa : mount


mossetto
01-04-2006, 20:35
Ciao a tutti. Volevo che qualcuno mi spiegasse: in knoppix ho sul desktop le icone dei dispositivi,in hda1 ho ntfs mentre in hdb5 ho fat32.Nel fstab compaiono tutt' due ma se dal menu a tendina classico seleziono montare su hdb5 va tutto ok mentre se lo faccio su hda1 mi dice:

Impossibile montare il dispositivo.
L'errore riportato :
Error opening partition device : Permission denied
Failed to startup volume : Permission denied
Couldn't mount device '/dev/hda1' : Permission denied
Mount failed.

mentre se provo da terminale come root dando :mount -t ntfs /dev/hda1 /media/hda1 (spero sia giusto ???) mi dice:

fusermount: failed to open /dev/fuse: No such file or directory
fuse_mount failed.

Qualche anima paziente mi pu spiegare come mai... mille grazie. :confused:

metal milita
01-04-2006, 22:08
prova a postare l'fstab.
all'inizio anche io ho avuto dei problemi a capire come funzionino le partizioni

mossetto
02-04-2006, 01:17
ecco:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdb2 / reiserfs defaults 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom2 /cdrom2 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom3 /cdrom3 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,users,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 /media/hda1 ntfs noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hdb1 none swap defaults 0 0
# Added by KNOPPIX
/dev/hdb5 /media/hdb5 vfat noauto,users,exec,umask=000 0 0

francofait
02-04-2006, 02:11
fusermount: failed to open /dev/fuse: No such file or directory
fuse_mount failed.

non trova il driver /dev/fuse

nel kernel di knoppix probabilmente compilato come modulo
prova a metterlo in /etc/modules e riavvia.

Loading