PDA

Visualizza la versione completa : configurazione skypho


alkat
23-04-2006, 21:22
Ciao,
sto provando a utilizzare Skypho ma non riesco a effettuare il login.

Mi sono registrato al sito e ho scaricato il software consigliato; inserisco tutti i dati necessari ma ogni volta ricevo il messaggio "login error".

Su Windows poi non ho nemmeno modo di aprire la finestra di configurazione: mi mostra solo la finestra di login. Su Linux invece riesco ad aprire il programma con la finestra di configurazione e il "telefonino".

Ho un router con firewall integrato (netgear dg834i) ma non ho ben capito come impostare le regole per Skypho, le spiegazioni del sito non mi sono molto chiare. Indicano una serie di porte da aprire, ma non so se in entrata o in uscita... Io le avevo aperte sia in entrata che in uscita ma non funziona comunque.

Chi mi dà una mano? Grazie.

.a.

Fool
24-04-2006, 23:44
Sul sito di skypho trovi la guida alla configurazione del firewall e dei vari sw/pa

alkat
25-04-2006, 13:25
Originariamente inviato da Fool
Sul sito di skypho trovi la guida alla configurazione del firewall e dei vari sw/pa

Grazie, a dire il vero però non ho trovato molto...

Ho trovato una tabella che elenca le porte da aprire, ma non capisco se devono essere servizi in entrata o in uscita o tutti e due.

.a.

Fool
25-04-2006, 14:23
Tutti e due :)

alkat
25-04-2006, 14:41
come immaginavo, io ho quindi impostato i servizi suggeriti, creandoli ad hoc e assegnando loro le porte indicate. non credo di aver commesso errori perché avevo usato la stessa procedura per amule. ciononostante continua a non connettersi: su Windows riesco solo a visualizzare la schermata di login (dopo l'errore di login, il programma si chiude da sé) mentre su Linux riesco a vedere il "telefonino" ma non riesco comunque a connettermi...

il servizio comunque funziona: ho attivato la segreteria telefonica e l'ho già testata.

.a.

Fool
25-04-2006, 14:44
che sw usi?

alkat
25-04-2006, 14:51
x-lite ma non mi dispiacerebbe provare qualcos'altro, magari open source.

.a.

alkat
25-04-2006, 14:57
i servizi creati sono questi:
7 STUN (UDP) 3478
8 SIP (UDP) 5060
9 RTP (UDP) 8000
10 RTCP (UDP) 8001

e li ho messi, come già suggerivi, sia in entrata che in uscita.

.a.

alkat
25-04-2006, 15:21
Ciao Fool,
ho letto la tua recensione di Skypho e vedo che usiamo lo stesso router, magari mi sai dire se la procedura che ho usato per aprire le porte è giusta o sbagliata.

1) Accedo alla pagina di configurazione del router
2) Seleziono Servizi sotto Filtraggio dei contenuti
3) Aggiungo servizio personalizzato:
----- Nome: STUN
----- Tipo: UDP
----- Porta iniziale: 3478
----- Porta finale: 3478
ripeto la stessa operazione per gli altri servizi necessari.
4) Vado su Regole firewall e aggiungo in entrata e in uscita i servizi appena creati (per i servizi in ingresso creo una regola per ogni IP registrato - ho più PC collegati al router).
5) Applico le modifiche ed esco.

Su Linux, apro il software X-lite e mi viene visualizzato il "telefonino" già citato che mi indica il mio numero ma mi dice Login failed! Contact Network Admin.

Hai qualche idea su cosa posso provare?

E dove va inserita la password? Non me la chiede... :master:

Grazie,
.a.

Fool
25-04-2006, 19:53
http://www.ngi.it/squillo/guide_voip/configurazione_xlite.asp

Prendi spunto da questa configurazione usando i parametri di Skypho

Per me il problema sta in xlite e non nel router, adesso volevo scrivere una guida alla conf del netgear per fare voip con vari trucchetti ma in questo momento non ho tempo :)

Prova a configurare il tuo client cosi e fammi sapere

P.s.... se usi KDE prove kPhone :D

ciao!

Loading