PDA

Visualizza la versione completa : [Debian]Problemino Lan-Internet


86frame
01-05-2006, 19:53
Ciao a tutti
ho appena installato una Debian sul mio pc e ho un problemino....ho una rete in casa formata da 2 pc collegati a internet con un router D-link 604T...stavo configurando internet facendo ifconfig,route add default gw 192.168.1.1,resolv.conf(ho messo ip del router)....finito tutto ho iniziato a testare la rete:
ping tra pc ok :)
ping con il router ok :)
ping www.google.it NO :cry:
non riesco ad andare su internet, ma non so cosa sia :dh: ....ho scordato qualche passaggio?avete qualche idea? :cry: ....AIUTO!!!!GRAZIE MILLE!!!



PS.cercando di trovare il problema ho visto che quando faccio il ping di www.google.it mi compare il suo ip quindi deduco che i DNS(che l'ip del router) funzionano.

PPS se entro con windows con lo stesso pc riesco ad andare su internet tranquillamente...

submax82
01-05-2006, 20:18
come DNS metti quelli della tua connessione... il dlink ha il dns proxy che non funziona bene.... quindi non mettere l'ip del router come dns sul pc.... ma metti i dns del tuo isp in resolv.conf vedrai che cos andr...

86frame
01-05-2006, 20:30
fatto ma niente...anzi se metto direttamente il dns sul pc quando pingo non mi dice neanche ip di google.....e poi sui pc con windows non uso dhcp e come dns ho messo il router e funziona.... :dh: :dh: :dh:

submax82
01-05-2006, 21:33
io sono abbastanza esperto dei router dlink ... sto facendo un firmware per il mio dlink 300t e ho partecipato a www.dlinkpedia.net ... ti posso consigliare SOLO SE HAI UN DLINK G604T di provare questi firmware http://www.mcmcc.bat.ru/dlinkt/dslg604t_20051210_03b_adsl2+_dsp4_firmware.rar se sei abbastanza esperto con l'uso di questo software http://www.webalice.it/rodicle/

86frame
01-05-2006, 21:37
non ne ho la pi pallida idea di firmware :rollo: ....cmq un occhiata gliela do!cmq non penso sia problema di router perch circa 3 mesi fa avevo la ubuntu su questo pc con lo stesso router e navigavo..... :dh: :dh: :dh: HELP :cry:

submax82
01-05-2006, 21:56
tienimi informato ... sono molto curioso della cosa...

Gen.Web
02-05-2006, 01:17
Originariamente inviato da 86frame
Ciao a tutti
ho appena installato una Debian sul mio pc e ho un problemino....ho una rete in casa formata da 2 pc collegati a internet con un router D-link 604T...stavo configurando internet facendo ifconfig,route add default gw 192.168.1.1,resolv.conf(ho messo ip del router)....finito tutto ho iniziato a testare la rete:
ping tra pc ok :)
ping con il router ok :)
ping www.google.it NO :cry:
non riesco ad andare su internet, ma non so cosa sia :dh: ....ho scordato qualche passaggio?avete qualche idea? :cry: ....AIUTO!!!!GRAZIE MILLE!!!



PS.cercando di trovare il problema ho visto che quando faccio il ping di www.google.it mi compare il suo ip quindi deduco che i DNS(che l'ip del router) funzionano.

PPS se entro con windows con lo stesso pc riesco ad andare su internet tranquillamente...

puoi postare il contenuto del file interfaces?

86frame
02-05-2006, 08:02
# This file describes network interfaces avilabla on your sistem
#and how to activate them.For more information,see interfaces(5)

#The loopback network interfaces
auto lo
iface lo inet loopback

#The primary network interface
auto eth1
iface eth1 inet dhcp

iface dsl-provider inet ppp
provider dsl-provider
#prease do not modifiy the following line
pre-up /sbin/ifconifg/ eth0 up # line maitained by pppoeconf

:confused: :confused: il file che preso /ect/network/interfaces.....spero sia quello giusto

mykol
02-05-2006, 09:18
io proverei a mettere, da console di root

# ifconfig eth0 192.168.1.100 up
(od un altro IP della classe di quello del tuo router)

# route add default gw 192.168.1.1

poi apri il file /etc/resolv.conf con un editor e ci scrivi (senza null'altro)

nameserver 212.216.112.112
nameserver 212.216.172.62

salvi, e dovresti navigare.

In alternativa (e per memorizzare i dati della connessione) prova anche ad avviare

# netcardconfig

scegliere NODHCP ed inserire i dati nei vari campi.

Se non presente sul tuo sistema, installala con

# apt-get install netcardconfig

Gen.Web
02-05-2006, 12:41
Originariamente inviato da 86frame
# This file describes network interfaces avilabla on your sistem
#and how to activate them.For more information,see interfaces(5)

#The loopback network interfaces
auto lo
iface lo inet loopback

#The primary network interface
auto eth1
iface eth1 inet dhcp

iface dsl-provider inet ppp
provider dsl-provider
#prease do not modifiy the following line
pre-up /sbin/ifconifg/ eth0 up # line maitained by pppoeconf

:confused: :confused: il file che preso /ect/network/interfaces.....spero sia quello giusto
io disattiverei la scheda di rete con ifdown eth0 (sempre che quello che ti interessa sia eth0), poi toglierei tutta la roba dopo "the primary network interfaces" e metterei

auto eth0
iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1

Poi ifup eth0
in modo tale da settare per il pc l'ip statico 192.168.1.5 e gateway quello da te voluto. Ho la sensazione comunque che quel file sia pastrocchiato da pppoeconf: se nn ti serve cancellalo.

Loading