PDA

Visualizza la versione completa : [ATI] L'accelerazione funziona o no?


aristarkos
09-05-2006, 16:29
Ciao a tutti,
ho appena concluso l'installazione dei driver ufficiali ATI su un Athlon X2 4200+ con scheda grafica ATI X1600 PCI-Express.
Al termine della procedura, Xorg si č avviato normalmente e tutto sembra andare. Non ho provato applicazioni che facciano forte uso di direct rendering, a parte qlk gioco (in cui non ho notato grandi differenze rispetto a prima)..

Mi č sorta qualke perplessitā dopo aver lanciato fglrxinfo da root e da utente normale; ecco gli output:

da utente normale:

$ fglrxinfo
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

da root:

# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Generic
OpenGL version string: 2.0.5755 (8.24.8)

A cosa č docuta questa diversitā di reazione?
Cosa devo pensare? Funziona o no questa accelerazione grafica?

Grazie a tutti!

aristarkos
09-05-2006, 16:51
Scusate il post inutile..
Mi sono risposto da solo e adesso funziona..
Comunque se servisse a qualcuno semplicemente mancava in fondo a xorg.conf la sezione:


Section "DRI"
Mode 0666
End Section

ciao

robyro
10-05-2006, 00:29
Originariamente inviato da aristarkos
Scusate il post inutile..
Mi sono risposto da solo e adesso funziona..
Comunque se servisse a qualcuno semplicemente mancava in fondo a xorg.conf la sezione:



ciao

potresti postare il tuo xorg.conf completo ?
ciao e grazie

aristarkos
10-05-2006, 16:05
Si, certo..
Eccolo..



Section "ServerLayout"
Identifier "X.org Default"
Screen 0 "aticonfig Screen 0" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/local/"
FontPath "/usr/share/fonts/freefont"
EndSection

Section "Module"
Load "dbe"
Load "record"
Load "extmod"
Load "dri"
Load "glx"
Load "xtrap"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection



ciao

Loading