PDA

Visualizza la versione completa : Problema avviio Synaptic


ghety
19-05-2006, 13:19
Ciao a tutti
su SimplyMeps ho aggiornato kde portandola alla 3.5.2 mediante synaptc e fin qui tutto bene
ma non mi parte + proprio synaptic.
Da shell qualsiasi pacchetto che decido di istallare/rimuovere (anche con -f install)
mi restituisce sempre questo messaggio:


Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
kdeutils gi alla versione pi recente.
consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kdeutils: Dipende: superkaramba (>= 4:3.5.2-1) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).

evidente che uno di questi 2 paccheti non va, ma non so cosa fare.
Che faccio??

Grazie a tutti

ghety
19-05-2006, 13:29
Scusate ma forse pi che un problema di synaptic un problema di apt che comunque non riesco a risolvere :messner:

francofait
19-05-2006, 13:44
Originariamente inviato da ghety
Scusate ma forse pi che un problema di synaptic un problema di apt che comunque non riesco a risolvere :messner:

dpkg --force-all --configure -a

andy caps
19-05-2006, 13:45
http://ftp.it.debian.org/debian/pool/main/k/kdeutils/superkaramba_3.5.2-1+b2_i386.deb

prova ad installargli quello che cerca al limite

dpkg -i superkaramba_3.5.2-1+b2_i386.deb

poi dovrebbe installare anche kdeutils

al limite rimuovi kdeutils provvisoriamente o cerca un sources.list diverso

ghety
19-05-2006, 13:52
Originariamente inviato da andy caps
http://ftp.it.debian.org/debian/pool/main/k/kdeutils/superkaramba_3.5.2-1+b2_i386.deb

prova ad installargli quello che cerca al limite

dpkg -i superkaramba_3.5.2-1+b2_i386.deb

poi dovrebbe installare anche kdeutils

al limite rimuovi kdeutils provvisoriamente o cerca un sources.list diverso

questo il messaggio

root@4[Desktop]# dpkg -i superkaramba_3.5.2-1+b2_i386.deb
(Lettura del database ... 99830 file e directory attualmente installati.)
Spacchetto superkaramba (da superkaramba_3.5.2-1+b2_i386.deb) ...
dpkg: errore processando superkaramba_3.5.2-1+b2_i386.deb (--install):
tentata sovrascrittura di `/usr/share/applnk/Utilities/superkaramba.desktop', che si trova anche nel pacchetto superkaramba-0.37-rc1
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Sono occorsi degli errori processando:
superkaramba_3.5.2-1+b2_i386.deb

ghety
19-05-2006, 13:53
Originariamente inviato da francofait
dpkg --force-all --configure -a

mi da ome ultimo messaggio:

dpkg: kdeutils: problemi con le dipendenze, ma configuro comunque come richiesto:
kdeutils dipende da superkaramba (>= 4:3.5.2-1); comunque:
Il pacchetto superkaramba non installato.
Configuro kdeutils (3.5.2-1) ...
Configuro kde (45) ...

e continua a non andare purtroppo

andy caps
19-05-2006, 13:55
prova a rimuovere superkaramba poi installare questo
al limite forzandolo
dpkg -i --force-all superkaramba_3.5.2-1+b2_i386.deb

prima prova come dice franco che usa mepis tutti i giorni e la conosce approfonditamente

francofait
19-05-2006, 13:55
le repositri debian sid ed etch attualmente sono sufficentemente in ordine x procedere
con un apt-get dist-upgrade anche con simply 3.4.X , non serve cambiare le repositry .
Simply si appoggia gi di suo alle repositri debian ufficiali e basta .

ghety
19-05-2006, 15:11
ne sono venuto a capo cos

# dpkg --force-all --configure -a

# dpkg -i --force-all superkaramba_3.5.2-1+b2_i386.deb

e poich inavvertitamente avevo anche disinstallato synaptic

# apt-get -f install synaptic

anche se credo che il -f non serviva

Grazie dell'aiuto

Loading