PDA

Visualizza la versione completa : Problemi PDC Samba


KaZaA
21-05-2006, 18:34
Salve a tutti! In questi giorni, gi ke nn sapevo quel ke fare, mi sono messo a smanettare con Samba per creare un Primary Domain Controller per Client Windows 2000/XP. Per la configurazione mi sono aiutato con Swat, ma ho aggiunto delle righe alla configurazione anke manualmente leggendo qu e l su internet le varie impostazioni. Il risultato il seguente:

[global]
workgroup = LINUX
server string = %h server (Samba, Ubuntu)
encrypt passwords = Yes
update encrypted = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
log file = /var/log/samba/log.%m
max log size = 1000
# add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u
# add machine script = /usr/sbin/useradd -d /dev/null -g machines -s /bin/false -M %u
logon drive = H:
domain logons = Yes
domain master = Yes

[netlogon]
path = /domain/users
read only = Yes
browseable = No
create mask = 0700
security mask = 0700
directory mask = 0700
directory security mask = 0700

[profiles]
comment = Cartella Condivisa
path = /domain/public
writable = Yes
read only = No
browseable = No

[homes]
read only = No
writable = Yes
create mask = 0700
directory mask = 0700
browseable = No

Quando vado ad aggiungere un client al dominio, funziona tutto alla perfezione ma, quando vado a riavviare il pc con windows 2000, all'avvio, mi spunta fuori un simpatico messaggio di errore ke mi avvisa ke un altro computer sulla rete ha il suo stesso nome e nn mi fa accedere al dominio dicendomi ke al momento nn disponibile. Ho provato a cambiare la configurazione + volte, ma senza risultato. Ho provato a cercare anke in rete una soluzione ma nn ho trovato nulla...mi potete aiutare? Grazie!

sacarde
21-05-2006, 19:10
un client linux funziona ?

KaZaA
21-05-2006, 19:51
Non lo s...per ora ho provato solo con un client Windows 2000...non ho altri computer disponibili al momento per fare delle prove con diversi sistemi operativi...

KaZaA
21-05-2006, 21:45
mmm...ho risolto cambiando il nome del NetBios ke prima era uguale a quello del Dominio...comunque ora quando provo a connettermi con il client al dominio con nome utente e password impostate nel file /etc/smbpasswd mi dice questo:

Impossibile Accedere al Dominio. L'account di sistema del computer nel suo dominio primario non presente o la password su quell'account non corretta

Me lo fa anke se nn scrivo nulla o se scrivo nome utente e password a caso...ke devo fare?

sacarde
21-05-2006, 21:54
questi li hai visti ?

http://www.sistemistiindipendenti.org/modules/news/article.php?storyid=33

http://www.sistemistiindipendenti.org/modules/news/article.php?storyid=38

http://www.sistemistiindipendenti.org/modules/news/article.php?storyid=122

Loading