PDA

Visualizza la versione completa : Suse 10.1 .. disastro pachetti


sylvaticus
10-06-2006, 10:57
Ok.. Suse l'unica che mi riconosce bene (quasi) tutto l'hardware del portatile... ma la gestione dei pacchetti semplicemente un disastro :-(((

Non riesco a capire.. ci sono decine di PMS (Package Management System.. non so se il termine si usa, l'ho inventata adesso ;-) ) ma alla fine un casino comunque.. mi ricordo i bei tempi di mandriva che andavi sul sito http://easyurpmi.zarb.org/, sceglievi i reposity e con un copia-incolla eri a posto.

Ora mi ritrovo con un programma di update che crasha, yast che anche se gli dico di rimuovere dei reposity non lo fa, un sacco di pachetti con broked dipendences.. la directory locale dei pachetti che non me la prende come reposity (lo faceva con la 10.0).. ecc..ecc.. eppure sto cercando di installare cose veramente basilari, come xfce ed ekiga..

Sylvaticus

francofait
10-06-2006, 11:08
Originariamente inviato da sylvaticus
Ok.. Suse l'unica che mi riconosce bene (quasi) tutto l'hardware del portatile... ma la gestione dei pacchetti semplicemente un disastro :-(((

Non riesco a capire.. ci sono decine di PMS (Package Management System.. non so se il termine si usa, l'ho inventata adesso ;-) ) ma alla fine un casino comunque.. mi ricordo i bei tempi di mandriva che andavi sul sito http://easyurpmi.zarb.org/, sceglievi i reposity e con un copia-incolla eri a posto.

Ora mi ritrovo con un programma di update che crasha, yast che anche se gli dico di rimuovere dei reposity non lo fa, un sacco di pachetti con broked dipendences.. la directory locale dei pachetti che non me la prende come reposity (lo faceva con la 10.0).. ecc..ecc.. eppure sto cercando di installare cose veramente basilari, come xfce ed ekiga..

Sylvaticus

Ripristina il dvd come fonte software , i pacchetti che cerchi li contiene tutti ed anche di pi e l'installazione diretta dal supporto sempre la + veloce.

sylvaticus
10-06-2006, 13:38
Da yast non riesco ad eliminare i reposity... cio lo faccio ma sti f.. ritornano.
Cque non credo che sul DVD ci siano..

..e non sono l'unico ad aver problemi con il nuovo sistema dei pachetti di suse 10.1:

da: http://www.linuxquestions.org/questions/showthread.php?t=446900

Lots of people are having problems with this new updater. Command line is supposed to work best, but 'best' isn't necessarily 'well'. There's a long post at planetsuse.org with some tips on how to get it working better, but realistically people are waiting for the SUSE team to update the new updater. How one might download any updates is another question!

Cos' questo "rug" ?? :( :(

sylvaticus
10-06-2006, 14:33
up... esiste un modo in suse per eliminare i reposity sia da YAST che da ZDD???

Quando provo ad eliminarli (TUTTI!!)...
intanto ci mette una vita a "pensare"...

poi mi da errori tipo questo:

rug failed to delete a ZYPP service:
ERROR: Can not find service 'http://packman.iu-bremen.de/suse/10.0'

Va b.. dall'update manager li ho gi rimossi... va b.. gli dico di salvare i cambiamenti comunque... ci mette altri 15-20 minuti per "pensare" e mi esce con quest'errore:

(dopo 30 minuti)
L'errore non me l'ha pi dato, ma i pachetti non me li ha cancellati :-(((

Esiste un modo a command line per ELIMINARE tutte le fonti???

sylvaticus
10-06-2006, 16:07
il package manager di yast, pur presentandosi in maniera simile, deriva da un sistema completamente nuovo.. ed strabugato .. :stordita: :stordita: sono un po' inc..to che hanno rilasciato una versione "stable" sapendo di un bug cos importante :jam: :jam:

c.que per chi interessa ho risolto con SMART.. molto bello:
http://spinink.net/2006/05/20/installing-smart-package-manager/

:ciauz: :ciauz:

mcz
10-06-2006, 18:23
E' uscita la patch:
Important SUSE Linux 10.1 update (http://lists.opensuse.org/archive/opensuse-announce/2006-Jun/0002.html)

mcz :ciauz:

A proposito diel link 'spinink.net', smart gi presente nel DVD di Suse. Basta installrlo con Yast.

sylvaticus
10-06-2006, 22:05
accidenti.. con yast non riesco a fare nulla.. mi ha trovato 200 MB di updates e poi quando ho dato ok sparito..

flygigi
15-06-2006, 16:23
A me proprio non funziona.

Con YOU non vedo nessun aggiornaento disponibile, quindi faccio fatica ad installare la patch come consigliato :dh:

sylvaticus
15-06-2006, 17:09
io credo che dovr reinstallarla e lanciare subito l'update.. avendo messo degli altri mirror ora non riesco pi ad aggiornare assolutamente niente.. semplicemente mi crasha.. :-(((

o forse per la presenza contemporanea di smart????

Loading