PDA

Visualizza la versione completa : [Samba] Autenticare client in dominio NT


scinti
10-06-2006, 16:37
La mia necessit quella di connetermi col mio computer portatile nel dominio della mia azienda, ma usando Linux (Mandriva/Kubuntu) mi sono un po' perso con la configurazione di Samba.
Ho installato anche Kerberos V per l'autenticazione, ma anche l ho fallito per scarse conoscenze.
Ho provato a leggere sul forum e cercare in rete, ma mi sono perso tra i vari LDAP e compagnia varia (ammesso che servano). Qualcuno ha voglia di aiutarmi? :smack:

Crypt
10-06-2006, 23:48
La rete una lan normale?
Come hai settato /etc/samba/smb.conf?

cacao74
11-06-2006, 01:12
Imposta opportunamente i password server verso il server di dominio.
Prova e facci sapere.

scinti
11-06-2006, 11:59
Originariamente inviato da Crypt
La rete una lan normale? E' una lan con DHCP, Firewall verso internet, Proxy, ecc. ecc.
La classe a cui noi dipendenti accediamo del tipo 10.x.x.x


Come hai settato /etc/samba/smb.conf? All'inizio in Linux era settata con SECURITY=USER, mi bastava per accedere ad internet e consultare il forum di html.it :D, per per accedere ai servizi interni richiesta l'autenticazione e ho impostato SECURITY=DOMAIN e REALM=ICT.terzolivello.secondolivello.IT (ehm, scusate la censura, ma...)


Originariamente inviato da cacao74
Imposta opportunamente i password server verso il server di dominio.Ecco, qu si entra in un campo che mi affascina, ma del quale sono ignorante.
Questo "password server" il l'account/password col quale io mi connetto normalmente da winzoz?
Ma non devo configurare anche kerberos?

Purtroppo il servizio ICT dell'azienda mi liquida con un laconico "non si pu" (e forse hanno anche ragione) senza neanche ascoltarmi.
So che voi mi capite quando io, invece, sostengo di voler usare la partizione di Linux invece che l'altra... (ormai c' la muffa su qui settori della partizione di winzoz).

Aspetto dritte su come procedere e cosa cercare. Grazie ancora.

Fabiuz
11-06-2006, 21:52
un dominio NT oppure win2003 con active directory???

scinti
12-06-2006, 10:46
Non saprei. I computer aziendali usano Winzoz 2000.
Comunque da un simpatico Nmap che ho appena eseguito direi 2003.

Starting nmap 3.81 ( http://www.insecure.org/nmap/ ) at 2006-06-12 10:39 CEST
WARNING: We could not determine for sure which interface to use,
so we are guessing 127.0.0.1 . If this is wrong, use -S <my_IP_address>.
Interesting ports on 10.55.8.101:
(The 1643 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE VERSION
53/tcp open domain Microsoft DNS
88/tcp open kerberos-sec Microsoft Windows kerberos-sec
135/tcp open msrpc Microsoft Windows msrpc
139/tcp open netbios-ssn
199/tcp open smux HP-UX smux (SNMP Unix Multiplexer)
389/tcp open ldap Microsoft LDAP server
445/tcp open microsoft-ds Microsoft Windows 2003 microsoft-ds
464/tcp open kpasswd5?
593/tcp open http-rpc-epmap?
636/tcp open ldapssl?
1025/tcp open msrpc Microsoft Windows msrpc
1030/tcp open iad1?
1370/tcp open msrpc Microsoft Windows msrpc
2301/tcp open compaqdiag?
3268/tcp open ldap Microsoft LDAP server
3269/tcp open globalcatLDAPssl?
3389/tcp open microsoft-rdp Microsoft Terminal Service
13722/tcp open netbackup Veritas Netbackup java listener
13782/tcp open VeritasNetbackup?
13783/tcp open vnetd Veritas Netbackup Network Utility
3 services unrecognized despite returning data.

scinti
14-06-2006, 13:28
Nessun aiuto? :(

scinti
16-06-2006, 15:25
:messner: up... ma poi basta, non lo faccio pi :nonono:

... solo che non so dove... :dh: (sbattere la testa)

Loading