PDA

Visualizza la versione completa : punto punto e hot spot, Risorse SI Internet NO!!!!!!!


pirolisi
15-06-2006, 11:04
Ciao ragazzi, scusate il titolo... ho cercato di metterci tutto il necessario.

Ho installato la mia 350esima rete wifi... e mi trovo al 350esimo mistero, "rete wireless che installi, mistero che trovi"!

Faccio una breve descrizione della struttura.

1) dlink dsl-524t - router adsl con 4 porte lan
2) dlink dwl-2100ap - configurato come ap e connesso tramite cavo a router
3) dlink dwl-2100ap - configurato come client e connesso all'ap 2 tramite wifi
4) dlink dwl-2100ap - configurato come bridge e connesso al client 3 con cavo crossover
5) dlink dwl-2100ap - configurato come bridge e connesso al bridge 4 via wireless
6) dlink dwl-2100ap - configurato come ap e connesso tramite cavo crossover al bridge 5

PS: ovviamente gli apparati da 1 a 4 si trovano in un edificio e il 5 e 6 in un altro edificio.

Tutti i pc e tutte le periferiche connesse in rete si vedono e sono pingabili.
Attualmente il collegamento adsl predefinito non ancora attivo, quindi volevo far navigare tutti i client della rete su internet attraverso la connessione fastweb che si trova nell'edificio con gli apparati 5 e 6.
tale connessione attiva da tempo tramite un router con porta wan e 4 porte lan della netgear. per mettero in rete con tutto il resto ho preso ancora un dwl-2100ap in modalita client, l'ho settato per connettersi all'ap 6 e con cavo l'ho connesso al netgear.
adesso da tutti i pc della rete il router netgear pingabile e amministrabile, dai tools presenti all'interno della sua interfaccia web di gestione posso pingare indirizzi esterni, ma da nessun pc collegato all'ap 2 ,con impostato l'indirizzo ip del netgear come gateway riesco a navigare.
se i pc li collego per con cavetto di rete al netgear o all'ap 6 oltre a funzionare tutte le risorse di rete navigano anche.

Vi viene in mente qualche cosa?

potrebbero entrarci i gateway dei singoli accesspoint/bridge e client?

Teoricamente no, ma credo di aver settato correttamente anche quelli.

e poi ricordo che l'indirizzo del netgear pingabile da tutti i pc, ma impostandolo come gateway non si naviga.

Grazie, scusate il post lungo ma volevo essere certo di spiegarmi bene.

bye

seclimar
15-06-2006, 11:20
wow...

bel casino che hai li ...


vediamo un po'
confermami tutti i passi!


1)
mi hai detto che tutti i pc pingano il router
e tutti i pc hanno come gateway il router
2)
immagino che quindi (tolti tutti i firewalls) tutti i pc possano pingare questo ip:
151.1.244.200

confermami
se i pc pingano quel ip vuole dire che anche internet va


3)
ora pinga www.html.it
se non va il dominio ma va l'ip .. magari non hai messo il dns ??


4)
tutti i pc sono nella stessa rete? quale classe di ip?
quale mask?
quale gateway ?
ecc...

pirolisi
15-06-2006, 11:25
Ciao,
innanzitutto grazie dell'interessamento....

tutti tutti i passi non te li confermo, perche se pingassi l'ip ma non il nome a dominio sarei apposto...

tutti i pc pingano il gateway, ma non vanno su internet, nessun servizio va su internet, tranne i pc connessi al primo AP.

pirolisi
15-06-2006, 11:41
Il collegamento fra le due sedi avviene tramite un bridge.
altri bridge secondari ci sono per il collegamento delle stampanti parallele alla rete wireless, che avviene con degli appositi adattatori, nel dettaglio i dwl-g810 che di fatto non sono che dei bridge, che convertono Virtualmente il segnale wifi in una porta ethernet.

Una cosa che mi veniva in mente poco fa leggendo su wikipedia l'open system interconnection e pensando ad un discorso fatto ieri con un mio amico/collega che spesso piu bridge sulla stessa rete si danno parecchia noia...

solo che, anche se fosse cosi... sti caxxo di bridge mi servono, quindi devono andare per forza.

:dh: :dh: :dh: :dh: :dh:

seclimar
15-06-2006, 12:04
per farmi capire bene dovresti rispondermi con precisione:

punto 1)
mi hai detto che tutti i pc pingano il router (qua mi hai confermato)
e tutti i pc hanno come gateway il router (ATTENDO CONFERMA)


punto 2)
ho capito che nessun pc pinga fuori tranne quelli della rete dove c'e' il gateway

punto 3)
non serve provarlo se non si pinga fuori


punto 4)
tutti i pc sono nella stessa rete? quale classe di ip?
quale mask?
quale gateway ?
ecc...

pirolisi
15-06-2006, 12:10
la classe utilizzata 192.168.0.0/24
la mask ovviamente 255.255.255.0
tutti i pc hanno come gw 192.168.0.1 che l'ip assegnato al router.

tutti i pc collegati alla rete nella zona del bridge dove presente il collegamento adsl vanno tranquillamente su internet.
Tutti i pc collegati alla rete nella zona del bridge dove non presente il collegamento adsl non vanno su internet.

Tutti i pc, indipendentemente da dove siano connessi si vendono l'uno con l'altro, pingano tutti il gateway, si scambiano file.

:)

seclimar
15-06-2006, 12:20
da un pc della zona A (che non va in internet)
pinga un pc della zona B (che funziona in internet)

poi viceversa gli stessi pc pingali dalla zona B alla zona A

mi raccomando tutte queste prove con i firewalls tolti (TUTTI)


se cosi' funziona e gli ip esterni continuano a non essere pingati, prova (SOLO SU UN PC DELLA ZONA A) ad abbassare leggermente il MAXMTU

forse e' quello
puoi trovare dettagli cercando qua o sul sito microsoft.COM
ICS MTU

pirolisi
15-06-2006, 12:26
tutti i pc indistintamente dalla zona nella quale si trovano si pingano fra loro e si scambiano file....


prover ad abbassare il MAXMTU dei pc della zona che non va in internet...
anche se non credo possa dipendere da quello... altrimenti non doveva andare neanche la rete locale fra i vari pc.

seclimar
15-06-2006, 12:29
non e' proprio cosi'..
poiche' magari i pacchetti grossi passano dall'AP .. ma non passano dal router che e' vincolato a pacchetti piu' piccoli

e' un problema noto quando si condivide una adsl con la ICS (internet connection sharing) ma che e' saltato fuori piu' volte anche con i router...

spesso il problema non e' neanche del tuo router, ma e' del GATEWAY del provider ...


insomma...
fai due prove cosi' ci togliamo i dubbi o lo confermiamo come causa...
mi raccomando ..quando lo abbassi...devi riavviare il pc. (non esagerare ad abbassarlo)

pirolisi
15-06-2006, 12:34
ok capito... ma forse ho delle lacune io e ti chiedo di colmarmele

se un pc della zona x va su internet e uno della zona y non ci va
controllare ed abbassare il valore mtumax potrebbe avere ottimi risultati se i pc non andassero neanche in rete fra loro.

come puo il router o il gateway del provider sapere da che parte della lan si trova il pc.

considera anche, come saprai, che il Bridge avviene a livello 2 datalink, mentre il routing a livello 3 network.

Grazie

Loading