PDA

Visualizza la versione completa : Problema installazione aMule


MisterBean
16-06-2006, 19:43
Ciao a tutti.
Non riesco a installare aMule, ho scaricato l'rpm dal sito ufficiale, e i sorgenti wxGTK, indispensabili per installarlo. Seguendo le istruzioni qui (http://www.amule.org/wiki/index.php/Compilation_Installation) mi d il seguente errore di compilazione quando cerco di eseguire "./configure --prefix=/usr --with-gtk --enable-unicode --disable-compat24 --enable-optimise && make"...

*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

Qualcuno pu aiutarmi?

MisterBean
16-06-2006, 21:30
Sono riuscito a installare tramite rpm aMule, ma quando lo eseguo da terminale mi esce il seguente messaggio d'errore


amule: /usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.2' not found (required by amule)
amule: /usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.3' not found (required by amule)

Ho cercato su Google, ma non sono riuscito a capirci molto riguardo alle librerie e a gtk. Cosa devo fare per installare questo WXU_2.6.3? :dh: :dh: :messner: :messner:

andy caps
16-06-2006, 21:39
che distribuzione usi ??

installandolo con i tool della tua distribuzione molto piu semplice

MisterBean
17-06-2006, 13:34
Uso una Mandriva Free 2006
Come faccio?
Devo impostare come origine dei pacchetti una cartella in cui li sposto tutti?

scinti
17-06-2006, 18:42
Fa parte delle librerie che sono in fase di sviluppo (come pachettizzazione rpm), prima di essere rilasciata come stabile. La trovi nella distribuzione Cooker.
Puoi scaricarle da un mirror italiano, ad esempio da qui (http://ftp://bo.mirror.garr.it/pub/1/mandrake/devel/cooker/i586/media/main/libwxgtku2.6-2.6.3-1mdk.i586.rpm).

andy caps
18-06-2006, 11:47
con mandriva ( spece se hai l'adsl ) si aggiungono i server di mandriva alle fonti di software

http://easyurpmi.zarb.org/index.php?language=en&user%5Bvers%5D=2006&user%5Barch%5D=i586&user%5Bpm%5D=urpmi

basta seguire la guida ed incollare in blocco le righe dei server ricavate in un terminale di root

se metti anche i plf ho visto che c' la versione 2.18 di amule

l'ultima versione sulla cooker ,come dice giustamente scinti ( la mandriva 2007 in sviluppo ) ma non credo le librerie siano compatibili con la versione 2006 ( le librerie sono spesso collegate tra di se e per aggiornarne una dovresti aggiornare il sistema spesso ?

se aggiungi i server poi amule lo trovi nel gestore software e scarica ed installa le dipendenze automaticamente dai server

MisterBean
18-06-2006, 13:08
Originariamente inviato da scinti
Fa parte delle librerie che sono in fase di sviluppo (come pachettizzazione rpm), prima di essere rilasciata come stabile. La trovi nella distribuzione Cooker.
Puoi scaricarle da un mirror italiano, ad esempio da qui (http://ftp://bo.mirror.garr.it/pub/1/mandrake/devel/cooker/i586/media/main/libwxgtku2.6-2.6.3-1mdk.i586.rpm).

Il link non funziona, porta a una pagina inesistente...
Ho seguito i passi nel sito illustratomi da andy caps, in seguito ho provato ad avviare aMule, ma niente, ancora quell'errore.

P.S. Potreste usare un linguaggio meno tecnico? Non sono per niente esperto in linux, sorry...

andy caps
18-06-2006, 13:52
http://easyurpmi.zarb.org

la pagina questa

devi solo leggere
dopo avere scelto la tua versione di mandriva e i server da aggiungere (come fonti di software) ai cdrom
selezionando dalla lista magari i server italiani delle varie voci
main
contrib
update
plf
plf-nonfree

passando alla fase 3 genera delle stringhe con i comandi preimpostati
devi solo poi copiare con il mouse l'intera sezione ed incollarla in una konsole ( che apri dal menu )
devi essere root nella consolle prima di incollare le stringhe altrimenti non riconosce nemmeno i comandi

per loggarsi come root nella consolle devi scrivere semplicemente
su
(esse u ) e mettere la password che hai scelto per l'utente root )

dopo i vari invio che devi dare una volta incollate le stringhe inizia a scaricare le liste dei pacchetti disponibili ( 30mb circa ) e quando ha finito con il semplice comando

urpmi amule

scarica ed installa amule e tutte le librerie necessarie a farlo funzionare

MisterBean
18-06-2006, 14:01
Allora sono quasi a posto.
Perch sono riuscito benissimo a cariare tutte le librerie necessarie (29 Mb), ma dopo ho digitato solo amule , non urpmi amule

MisterBean
18-06-2006, 14:19
Come non detto...
ho seguito tutti i passi del sito e installato tutto, ma al momento di digitare "urpmi amule"
mi comparso l'errore seguente:


In preparazione... #############################################
Installazione fallita:
file /usr/bin/alc from install of amule-2.1.0-1.1.20060plf conflicts with file from package aMule-2.1.3-wxGtk2.6.3_mdv
file /usr/bin/amule from install of amule-2.1.0-1.1.20060plf conflicts with file from package aMule-2.1.3-wxGtk2.6.3_mdv
file /usr/bin/amulegui from install of amule-2.1.0-1.1.20060plf conflicts with file from package aMule-2.1.3-wxGtk2.6.3_mdv
file /usr/bin/cas from install of amule-2.1.0-1.1.20060plf conflicts with file from package aMule-2.1.3-wxGtk2.6.3_mdv
file /usr/bin/wxcas from install of amule-2.1.0-1.1.20060plf conflicts with file from package aMule-2.1.3-wxGtk2.6.3_mdv

Loading