PDA

Visualizza la versione completa : [suse 10.1] installazione vlc


GunMan
20-06-2006, 23:52
sono spiacente di infastidirvi nuovamente con il miei problema da principiante, tuttavia non so più cosa inventarmi.

sto cercando invano di installare VLC, ho scaricato un pò ovunque diversi .rpm ma nessuno per un motivo o per l'altro pare funzionare.

primo caso:

scarico questo file vlc-0.8.5-2.pm.3.src.rpm da Qui (http://rpm.pbone.net/index.php3/stat/26/dist/48/size/8458387/name/vlc-0.8.5-2.pm.3.src.rpm) e il software installer restituisce il seguente errore:


Unable to locate the specified packages.

a questo punto ho cercato altri .rpm e mi sono imbattutto in questi file:

vlc-0.8.5-2.pm.3.i586.rpm
vlc-0.8.5-2.pm.3.src.rpm
vlc-debuginfo-0.8.5-2.pm.3.i586.rpm
vlc-devel-0.8.5-2.pm.3.i586.rpm

ho immaginato che andassero tutti installati, percui selezionandoli ho avviato il software installer come sopra, e questo è l'errore presentatomi:


Unresolved dependencies:
Installing vlc-0.8.5-2.pm.3.i586[Local packages]
There are no installable providers of libx264.so.46 for vlc-0.8.5-2.pm.3.i586[Local packages]

bene, l'errore è abbastanza eloquente, quindi mi sono messo a cercare questo libx264.so.46 e al medesimo link di prima ho trovato il seguente file, anch'esso rpm:


Unresolved dependencies:
Installing x264-0.0svn20060425-1.i586[Local packages]
There are no installable providers of nasm for x264-0.0svn20060425-1.i586[Local packages]

vi sarei grato per qualsiasi consiglio o indicazione, purtroppo per me la cosa sta diventando grottesca

:stordita:

saluti :)

GunMan
21-06-2006, 13:13
piccolo UP, ancora non sono riuscito a risolvere nulla...con kaffeine ho problemi a vedere video in .avi .mpg (finora le due estensioni provate) pensavo di poter risolvere installando i codec ma ahimè non ho fatto altro che girarci intorno.

ho pensato di installare vlc (programma che già ho avuto modo di usare ed apprezzare) ma i tentativi sono stati vani...

è gradito ogni genere di suggerimento, grazie ancora per l'attenzione

saluti :)

AmeDSL
21-06-2006, 13:45
Che desktop manager usi?Cmq se usi KDE non avresti bisogno di VNC potresti usare Krdc(con la sintassi VNC:/indirizzoip).Per i codec hai provato ad installare win32-all ?(altrimenti installali con Yast aggiugendo il repo di packman)Fammi sapere.

GunMan
21-06-2006, 13:53
ciao AmeDSL, innanzitutto grazie per la risposta e la pazienza, la distro l'ho inserita nel titolo, errore mio non averla rispecificata :)

uso suse 10.1 e kde 3.5.1, perdona l'ignoranza ma io menzionavo VLC (VideoLAN Client) e non VNC, spero di non dire fesserie ma dovrebbero essere abbastanza diverse come applicazioni.

così come hai accennato ho tentato di scaricare ed installare i codec necessari per il corretto funzionamento di Kaffeine.

soprattutto non sono riuscito, anche dopo diversi tentativi e innumerevoli readme a capire l'esatto modo di procedere.

grazie ancora :)

AmeDSL
21-06-2006, 14:04
No quello che ha detto fesserie sono io :D non avevo ben letto :D
Cmq personalmente VLC mi ha dato un sacco di problemi con Suse sia nella risoluzione delle dipendenze che nella stabilità del sistema(quando dopo parecchi tentantivi sono riuscito ad installarlo).Consiglio pratico tieniti kaffeine ed installa i w32codec (da qui se non riesci da yast http://packman.links2linux.de/download.php?t=b&id=22422 )Fai quest'altra prova e fammi sapere.

GunMan
21-06-2006, 14:24
grazie ancora AmeDSL, appena tornerò a casa dal lavoro e potrò mettere la mani sul mio pc cercherò di risolvere.

in ogni caso grazie per l'interessamento, comunque vada posterò in seguito i risultati :)

saluti

GunMan
21-06-2006, 14:58
niente da fare...anche dopo aver scaricato e installato con successo il pacchetto dei codec l'errore con kaffeine è il medesimo:


xine: non trovo il demux per >/home/le_gauche/Desktop/1.mpg<
xine: found input plugin : plugin di input del file

tra l'altro se provo ad avviare kaffeine dalla sheel di root mi viene mostrano questo errore:


linux-j9aj:~ # kaffeine
kbuildsycoca running...
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
DVB 0 : No such file or directory
DVB 1 : No such file or directory
DVB 2 : No such file or directory
DVB 3 : No such file or directory

il problema pare sia più grande del previsto...o forse è solo la mia incompetenza

se magari qualcuno ha già passato una simile situazione e può darmi un consiglio o un'indicazione glie ne sarei grato.

saluti :)

francofait
21-06-2006, 15:28
Originariamente inviato da GunMan
niente da fare...anche dopo aver scaricato e installato con successo il pacchetto dei codec l'errore con kaffeine è il medesimo:



tra l'altro se provo ad avviare kaffeine dalla sheel di root mi viene mostrano questo errore:



il problema pare sia più grande del previsto...o forse è solo la mia incompetenza

se magari qualcuno ha già passato una simile situazione e può darmi un consiglio o un'indicazione glie ne sarei grato.

saluti :)

kaffeine richiede l'avvio diretto da x
lo trovi nella cartella multimedia.

GunMan
21-06-2006, 16:01
ciao francofait e grazie per la pronta risposta, ti chiedo scusa ma non ho ben capito il da farsi leggendo il tuo post, ovviamente per mia ignoranza.

ho cercato il lungo e in largo questa cartella multimedia senza successo, potresti cortesemente spiegarmi?

grazie ancora

saluti :)

AmeDSL
21-06-2006, 20:53
Apri yast seleziona gestione pacchetti nela campo di di ricerca inserisci "kaffeine" a destra ti apparira un menu con delle vici selezionate cliccacci sin che nonj diventeranno verdi(con una specie di fulmine disegnato)in questo modo aggiornerai il software o nel peggiore dei casi lo reinstallerari.Fammi sapere

Loading